Go Back   Rangefinderforum.com > Cameras / Gear / Photography > Leicas and other Leica Mount Cameras > Leica SL

Reply
 
Thread Tools Search this Thread Display Modes

Old 05-11-2018   #41
airfrogusmc
Registered User
 
airfrogusmc is offline
Join Date: Nov 2012
Posts: 5,661
Quote:
Originally Posted by Huss View Post
I tried one out and did not feel that it gave me any advantages in actual use over the M240 I already had. And the pics that people have posted with the M10 - very nice but again I do not see any difference.

I don't know if the profiles issue is moot as while LR does have M lens profiles if you shoot in RAW, so you can pick anything you want, I don't think it corrects for pink edges etc. From what I've seen only for distortion and vignetting.

Right now I'm only musing really, but one thing may lead to another.

And yes, Leica service does absolutely suck. So there is that. The people in the LeicaStores have been wonderful, but if the camera needs to get sent to NJ (in the US) then enjoy watching the seasons change...
Huss I have a 262 and an M 10 and the M 10 is more responsive. No lag at all which the 262 and 240 can have at times.M 10 20,000 ISO is very usable and 3200 can band in the shadows or with underexposure with the 262. The M 10 would also be me advice.
  Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 12:08.


vBulletin skin developed by: eXtremepixels
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

All content on this site is Copyright Protected and owned by its respective owner. You may link to content on this site but you may not reproduce any of it in whole or part without written consent from its owner.