Go Back   Rangefinderforum.com > Cameras / Gear / Photography > Classic Film RangeFinders & Other Classics > Kodak Retina and Ektra Rangefinders

Kodak Retina and Ektra Rangefinders This forum is for 35mm Kodak Retinas and Ektras rangefinders. The Retinas are known for their German engineering, relatively modest price and superb lenses. The Ektras are known as by far the finest 35mm American made rangefinder ever made.

Reply
 
Thread Tools Search this Thread Display Modes

Kodak Type 021 Model I Retina IIIc w/ Rodenstock 50mm f/2.0 Heligon
Old 1 Week Ago   #1
Sumarongi
Registered User
 
Sumarongi's Avatar
 
Sumarongi is offline
Join Date: Feb 2018
Posts: 230
Kodak Type 021 Model I Retina IIIc w/ Rodenstock 50mm f/2.0 Heligon

Just yesterday, and absolutely by chance (I was buying a tripod), I bought a Kodak Type 021 Model I Retina IIIc w/ Rodenstock 50mm f/2.0 Heligon

(For a song, I might add )

Problem: 1/60 and faster seem O.K., but slow speeds are sticky.

How can I reactivate the slow speeds without any surgery, if possible?
__________________
**Any feature is a bug unless it can be turned off.** (Daniel Bell Heuer's Law.)
  Reply With Quote

Old 1 Week Ago   #2
Phil_F_NM
Camera hacker
 
Phil_F_NM's Avatar
 
Phil_F_NM is offline
Join Date: Jun 2004
Location: Philadelphia, PA
Age: 42
Posts: 3,597
You may be able to get better slow speeds by warming up the camera but this is a temporary fix. The only solution to this common issue is a CLA on the shutter.

Phil Forrest
  Reply With Quote

Old 1 Week Ago   #3
Arbitrarium
Never trust a light meter
 
Arbitrarium's Avatar
 
Arbitrarium is offline
Join Date: Aug 2016
Posts: 281
I've only used a Retina II but I think the III also has a removable front element that just unscrews easily. If you can get to the shutter blades, try dabbing a bit of naptha onto them and firing the shutter a few times. Repeat until the speeds free up.

And yeah, warming it up might help. My Retina hated being cold and refused to function in Lapland in March... Zorki 4 shrugged it off =P
__________________
Arbitrarium on Instagram
  Reply With Quote

Old 1 Week Ago   #4
Sumarongi
Registered User
 
Sumarongi's Avatar
 
Sumarongi is offline
Join Date: Feb 2018
Posts: 230
Quote:
Originally Posted by Phil_F_NM View Post
You may be able to get better slow speeds by warming up the camera but this is a temporary fix. The only solution to this common issue is a CLA on the shutter.

Phil Forrest
Quote:
Originally Posted by Arbitrarium View Post
I've only used a Retina II but I think the III also has a removable front element that just unscrews easily. If you can get to the shutter blades, try dabbing a bit of naptha onto them and firing the shutter a few times. Repeat until the speeds free up.

And yeah, warming it up might help. My Retina hated being cold and refused to function in Lapland in March... Zorki 4 shrugged it off =P
Thank you both!

My memory is a seeve, apparently
-- In winter 2017/18 I put another leaf shutter camera simply for some hours near the radiator, and in fact, for I guess some hours, even in the -5C outside, the things in question were *liquefied* again, so to say

edit: a sieve, of course
__________________
**Any feature is a bug unless it can be turned off.** (Daniel Bell Heuer's Law.)
  Reply With Quote

Old 1 Week Ago   #5
Beemermark
Registered User
 
Beemermark's Avatar
 
Beemermark is offline
Join Date: Jan 2007
Location: Wilmington, NC
Posts: 1,549
Quote:
Originally Posted by Arbitrarium View Post
I've only used a Retina II but I think the III also has a removable front element that just unscrews easily. If you can get to the shutter blades, try dabbing a bit of naptha onto them and firing the shutter a few times. Repeat until the speeds free up.=P

Good advice. Lighter fluid works well also to loosen the dried grease and ( I think) it might provide a very wee bit of lubrication. You have to be able to it without it getting on the lenses though.
  Reply With Quote

Old 1 Week Ago   #6
Sumarongi
Registered User
 
Sumarongi's Avatar
 
Sumarongi is offline
Join Date: Feb 2018
Posts: 230
Quote:
Originally Posted by Beemermark View Post
Good advice. Lighter fluid works well also to loosen the dried grease and ( I think) it might provide a very wee bit of lubrication. You have to be able to it without it getting on the lenses though.
Hmmm... (my brain-sieve) yes, I have Zippo fluid at home, although I don't have any Zippo lighter -- an ad writer would say: *Zippo is Synchro Compur's friend*, or so?
__________________
**Any feature is a bug unless it can be turned off.** (Daniel Bell Heuer's Law.)
  Reply With Quote

Old 1 Week Ago   #7
retinax
Registered User
 
retinax is offline
Join Date: Aug 2015
Posts: 509
I have found on my IIIC the shutter blades as well as the slow speed escapement needed cleaning. So a fair bit of disassembling was needed. It's doable for the patient and inclined layman, but fiddly. Check out Chris Sherlock's website and YouTube videos.
  Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 12:10.


vBulletin skin developed by: eXtremepixels
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.

All content on this site is Copyright Protected and owned by its respective owner. You may link to content on this site but you may not reproduce any of it in whole or part without written consent from its owner.