Go Back   Rangefinderforum.com > Cameras / Gear / Photography > Classic Film RangeFinders & Other Classics > Olympus RF

Olympus RF This forum is for the Olympus rangefinders.

Reply
 
Thread Tools Search this Thread Display Modes

Olympus 35 RC problem with shutter speeds
Old 1 Week Ago   #1
mayqueen
Registered User
 
mayqueen is offline
Join Date: Oct 2019
Posts: 1
Olympus 35 RC problem with shutter speeds

Recently got the 35 RC. Upon inspection the shutter speeds, I've noticed they all sounded similar. Tested it with a roll of UltraMax 400 and photos on all speeds but 1/15 and 1/30 are correctly exposed, 1/30 and 1/15 look underexposed.
Light meter works and the same effect is present whether shot in Automatic or fully manual mode.
Has anyone had such problem? I'm wondering if it could be repaired.
  Reply With Quote

Old 1 Week Ago   #2
charjohncarter
Registered User
 
charjohncarter's Avatar
 
charjohncarter is offline
Join Date: Dec 2006
Location: Danville, CA, USA
Posts: 8,775
I've had shutter problems but not that one. I had to send mine to be fixed.
  Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 12:35.


vBulletin skin developed by: eXtremepixels
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

All content on this site is Copyright Protected and owned by its respective owner. You may link to content on this site but you may not reproduce any of it in whole or part without written consent from its owner.